What are the minimum system requirements for your courses?

The following are the minimum requirements for our courses:

Operating System:

  • Windows 10 (32-bit or 64-bit)
  • Windows 8 (32-bit or 64-bit)
  • Windows 7 SP1 or later (32-bit or 64-bit)
  • Mac OS X 10.6.8 or later

HTML5:

  • Windows: Internet Explorer 11, Microsoft Edge (latest version), Google Chrome (latest version), Firefox (latest version)
  • Mac: Safari (latest version), Google Chrome (latest version), Firefox (latest version)
  • Mobile: Safari in Apple iOS 10 or later, Google Chrome in Apple iOS 10 or later, Google Chrome in Android OS 4.4 or later

Flash:

  • Adobe Flash Player 10.3 or later plus any of these web browsers:
    • Windows: Internet Explorer 8 or later, Microsoft Edge (latest version), Google Chrome (latest version), Firefox (latest version)
    • Mac: Safari (latest version), Google Chrome (latest version), Firefox (latest version)

Still need help? Contact Us Contact Us